Matt Mullenweg 23.04.2017 Tarihinde WordPress Blog sayfasında yazdığı yazıyı sizlerle paylaşıyoruz.

Daha önce, WordPress çekirdeği içinde yeni düzenleyici ve tarayıcı desteğini tartıştık. Bu konuşmaları takip ederek, WordPress 4.8’den itibaren Internet Explorer sürüm 8, 9 ve 10 için resmi olarak destek vermeye başlıyoruz.

Microsoft, bu tarayıcıları 2016 yılının Ocak ayında desteklemeyi resmen bıraktı ve kendilerini desteklemeye devam etmeye çalışmak, gelişmeyi geride bıraktığı noktada bizi engelledi. Bu tarayıcıları çalıştıran kişilerin, muhtemelen kütüphane ya da başka bir şey gibi kontrollerinden mahrum kaldıklarından habersiz olduklarını anlıyorum. Nasıl hesapladığımıza bağlı olarak, toplam tarayıcıların% 3’ü ya da toplam kullanıcıların% 1’inin altında, ancak her iki durumda da WordPress’in test etmeye ve geliştirmeye devam etmesinin eşiğin altına düştüğü düşünüldü. (Rakamlar beni şaşırttı, bununla birlikte IE pazar payının genel olarak ne kadar düşük kaldığını da gösterdi.)

Elbette, wp-admin bu eski tarayıcılarda çalışmaya devam etmeli, ancak daha az yetenekle çalışmalı ve artık bu tarayıcılarda yeni özellikler ve geliştirmeleri test etmiyoruz. Örneğin, şu anda WordPress 4.8’i hedefleyen TinyMCE’nin sonraki sürümleri eski IE tarayıcılarını desteklemiyor.

Bu değişikliğin bir parçası olarak, Browse Happy bu tarayıcıların artık desteklenmediğini göstermek için güncellemeye çalışacağız ve kullanıcıları tarayıcıları yükseltmeye veya tarayıcıları değiştirmeye teşvik edeceğiz.

Kaynak: https://make.wordpress.org/core/2017/04/23/target-browser-coverage/

WordPress 4.8 ile İnternet Explorer Desteği Geliyor
4.6 (91.11%) 9 Oy verildi.